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Saving Images for the Web: 
The best way to optimize images for the web is through the Save for Web command available 
from the File menu.  This command changes your color modes, if needed, as well as converting 
the file format of your image.   
 

Tools 
 

 
Tabs 

   Next, you may notice four tabs across the top of the 
window:  Original, Optimized, 2-Up, and 4-Up.  The first tab displays the original image, the 
second a version of the image optimized for web display.  The 2-Up and 4-Up let you compare 
the original with either one or three options for optimizing the image.    With the button to 
the right of the tabs, you can select more advanced options for viewing your optimized image.  
You can see what it would look like on another platform (such as a Macintosh, if you were 
working in Windows). 

 

Zoom Level Display 
After you click on File > Save for Web, you will see more information across the bottom of the 
Save for Web window.  From the left, you’ll see a Zoom level display that can be altered by 
using the drop down menu or by typing a number over the current percentage.  The row of letters 
that follow display color information from a single pixel that you select from your image with 
the Eyedropper. 

 

In the upper left-hand corner, you will see a column of tools.  
• Hand tool  
• Slice Select tool 
• Zoom tool 
• Eyedropper 
• Eyedropper color display  
• Toggles Slices Visibility tool. 

No matter which tab you’ve selected for 
viewing your image, you will see 
information about that image at the 
bottom of each window.  You will see the 
file size, the required download time, as 
well as the optimization levels you’ve 
chosen for that image. 
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Image Size tab 

 

JPEG images 

 
You can use the Quality Slider (click the down arrow) to make small changes to the image 
quality and then preview the difference.  Again low will generate a smaller file size and 
maximum will generate a larger file size.   

If you check the Optimized feature, your file size will be smaller but may not be compatible with 
older browsers.  If this feature is on, you can also choose the Progressive option, which displays 
your image to users in a series of overlays, displaying a low image until the complete image 
finishes downloading.   

GIF images 

 
• Perceptual preserves the colors that appear most often in the image and are more easily 

seen by the eye; this setting usually provides the greatest color integrity. 
• Selective uses the preservation of broad areas of color and web-safe colors. 
• Adaptive preserves the colors that appear most often in the image. 
• Web consists of only 216 web-safe colors. 

Toward the bottom right of the window, you’ll see an 
Image Size tab with which you can resample your 
optimized image (change the number of pixels in the 
image).  Note that you cannot change the resolution 
here; you have to use the Image Size command from the 
Image menu instead.   
 

By selecting the JPEG settings from the drop-down 
menu, you can set the compression quality level below 
the file format list: you can choose a level anywhere 
between low and maximum.  Low will be a smaller 
file size and Maximum will be a larger file size.  
Maximum is usually overkill — your users won’t even 
notice this setting.

GIFs are usually the primary format for the 
web.  Colors are limited to 256 or less through 
a color mode called Indexed Color.  GIFs use a 
lossless compression method, which means 
that they don’t discard pixel information like 
JPEGs do.  GIFs support transparent areas in 
your image.   
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• Custom preserves the current perceptual, selective, or adaptive color table and it does not 
update with changes to the image. 

Now that you have chosen your settings, it’s time to see whether you can further reduce the colors 
in your image for an even smaller file size.  Try setting the Colors to 128; look at your file size.  
You can also try Diffusion, Pattern, or Noise from the dither drop down menu. 
 
Each of these methods attempts to substitute colors that exist in the color table for colors outside 
that complete subset of colors in the image.  The pattern method replaces pixels in a square 
pattern, while the diffusion method uses a randomized technique that may leave some “seams”; 
the noise method uses random replacement that does not cause seams.  To control the amount of 
dithering in your image, use the slider bar next to Dither. 
 
Note:  Increasing dithering levels will slightly increase your file size.  But it may not increase 
your file size as much as adding more colors to your image would. 
 
The Color Table 

 
 
Another option for reducing the overall number of colors while protecting certain colors is the 
lock a color(s) in the color table.  Select the color you would like to lock with the Eyedropper, 
then click on the lock icon at the bottom of the palette.  When you reduce colors next time, the 
colors you locked will be protected.   
 
Finally, you may want to investigate interlacing and lossy options.  With the Lossy slider you 
can apply a lossy compression method, much like the one used to compress a JPEG, to further 
reduce your file size.  You may be able to set this slider to between 5 to 10 without losing 
significant image quality.   
 
The Interlace feature is much like the Progressive option for JPEGs:  a low-resolution version 
of your image displays to the user while the full image completes the loading process.  Note that 
interlacing an image usually increases the file size. 
 

You can get additional information about the colors 
in your image from the Color Table, which displays 
all the colors currently indexed in the image.  
Photoshop will mark web-safe colors in the table with 
a diamond in the center.  You can select a color from 
the image, either from the table or by picking it with 
the Eyedropper tool directly from the image, and 
“snap” it to the nearest web-safe color by clicking on 
the cube icon at the bottom of the Color Table 
palette.  You can also set the Web Snap slider to 
increase the percentage of web-safe colors in your 
image.  You may want to use the palette drop-down 
menu to select certain colors in the table or to 
organize them.  
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Images in HTML 
Once you’ve optimized your image, you need to know a little bit about adjusting its appearance 
on your web page.  The tag that you will be using to work with any image element in HTML is 
<IMG>.  This tag allows you to place and have some formatting control over in-line images in 
your HTML document.  It cannot be used for embedding other HTML text.  The image element 
is empty, which means that it does not have a closing tag.   
 
Attribute Options Descriptions 
src="" URL The URL of the image to be embedded.  SRC is mandatory 
lowsrc="" URL Load two images in the same space (usually one of a 

smaller file size that will appear while the larger image 
loads). 

border="value" numeric values Lets you control the thickness of the image border (in 
pixels).   

width="value" numeric values Manually sets the image width 
height="value" numeric values Manually sets the image height 
vspace="value" numeric values Controls the vertical space above and below the image. 
hspace="value" numeric values Control the horizontal space around an image. 
alt="" text string Optional text used as an alternative to the image in text-

only browsers. 
align="value"  Alignment of the image relative to other parts of your 

document. 
 left Image will align to the left margin, text will wrap around it 
 right Image will align to the right margin, text will wrap around 

it 
 top Aligns itself with the top of the tallest item in the line. 

 
 texttop Aligns itself with the top of the tallest text in the line 

(usually no different then top) 
 middle Aligns the baseline of the current line with the middle of 

the image. 
 absmiddle Aligns the middle of the current line with the middle of the 

image. 
 baseline Aligns the bottom of the image with the baseline of the 

current line. 
 bottom Same as baseline above. 
 absbottom Aligns the bottom of the image with the bottom of the 

current line. 
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Background Images 
You may want to use an image as the background for your web page.  While an image can create 
a depth and texture impossible to achieve with a flat background color, it may also pose 
problems for your viewers.  If the image is too busy, it may prevent viewers from reading the 
text on your page.  A background image could be more distracting than enhancing unless you 
plan ahead. 

It’s usually best to save your background images as GIFs for two reasons:  first, a GIF image is 
smaller than a JPEG and will load more quickly, and second, JPEGs may look blotchy in areas of 
continuous-tone shading once dithering has occurred.  But since you’ll often need to make 
adjustments to the image in Photoshop before adding it to your web page, you should work in 
RBG Color mode until your editing is completed.  

Here are a few tips for editing images to be used as backgrounds: 
• Make your background more subtle so that it doesn’t interrupt your text.   
• Consider using the Edit, Fill command with a fill color of White or 50% gray and a low 

Opacity setting.   
• You may also want to experiment with the Blending Modes (Lighten might be 

particularly useful).  
 
Filters provide other means of reducing the prominence of your background.  Gaussian Blur or 
one of the Artistic filters might be helpful. 
 
Remember that all images set as the background for a web page will automatically be tiled.  
When you want to preview the way your background might look on a web page, select it using 
the rectangular marquee tool.  Remember that just as on a web page, your background must be in 
a rectangular shape.  Set that selection as a pattern using Edit, Define Pattern.  Then create a new 
document with a size of 640 X 480 pixels (approximately the size of a v viewer’s monitor) and 
fill it using Edit > Fill with the Contents set to Pattern.  You can now see how your tiled 
background will look. 

Transparency in Images 
To make your pages look truly professional, you may want to create some images that blend into 
the background that you just created without a distinct background color of their own.  To do so, 
you can create a transparent GIF or PNG.  Photoshop offers several ways to add transparency to 
your image:  the Transparent Image Wizard, the Background Eraser, the Magic Eraser, and 
the Extract command.  The method you choose to add transparency to your image will depend 
on how difficult it is to select or isolate the area that is to be transparent. 

Transparent Image Wizard 
If the area to be made transparent is easily selected, you will want to use a simple option, such as 
the Transparent Image Wizard; the wizard will walk you through the process, step-by-step.  The 
downside to using this feature is that it doesn’t give you as much control over optimization 
settings as the Save for Web command.  From the Help menu, select Export Transparent 
Image.  Select the second radio button, indicating that you have already made your selection, 
and click next.  The remaining windows will ask you to select the end-use for your image (print 
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or online), the file format (GIF or PNG) as well as final conversion information, depending on 
your format choice.  If you select the GIF format, you will be asked to select the color reduction 
algorithm as you would in the Save for Web window.  Be sure to check the box for Transparency 
so that Photoshop will preserve the transparency of the selected pixels.  After you have saved the 
file, you may see a gray and white checkerboard pattern in the areas that were made transparent; 
this is Photoshop’s way of displaying transparency.  To change this setting, use the Preferences 
command from the Edit menu and choose the Transparency and Gamut option. 
 

 

The Background Eraser 
To use the Background Eraser, select it from the toolbox and select a brush size; as with the painting 
tools, you have the option of fading your brush stokes using the Brush Dynamics settings.  Set the 
limits according to the kind of control you want Photoshop to exercise over your erasing to 
transparency: 

 
   

• Discontiguous erases the sample color wherever it exists under the tool. (The plus sign in 
the center of the cursor indicates the tool’s “hotspot”.) 

• Contiguous erases colors that are under the brush and touching each other. 
• Find Edges erases the color under the brush while doing a better job of preserving shape 

edges. 

The Magic Eraser 
If the area you want to make transparent is the same color throughout your image, or if you wan t 
to make a particular color or colors transparent, you should use the Magic Eraser.  It works very 
much like the Magic Wand tool, except instead of selecting the area you click on, you’ll erase it 
to transparency.   

The Background Eraser and Magic Eraser 
Found under the Eraser tool, they offer two options for 
converting color pixels to transparency.  
  
The Background Eraser converts pixels to transparency as 
you click and drag, allowing you to “erase” areas to 
transparency.  The Magic Eraser works like the Magic 
Wand tool, converting all the pixels of a particular color 
in the image (or selection) to transparency.   
 
You may want to use the first option when the area you 
wish to erase contains colors that are also in the 
foreground of the image; the second option is more useful 
if the area to be made transparent doesn’t share colors in 
common with the foreground. 
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The Extract Command 

 
 
 
 
Once you’ve previewed the image, you may discover that you need to make some adjustments.  
Use the cleanup tool to make areas that shouldn’t have been included in your selection 
transparent.  The Edge Touchup tool will help you sharpen the edges of your selection.  
Conversely, if you need to tone down overly sharp edges, set the Smooth slider above 0.  If after 
these adjustments, you find that you need to start over altogether, select Original from the 
preview drop-down menu and check on the boxes to Show Highlight and Show Fill.  If you’re 
happy with the extraction, click OK to perform it.  You will now see your selection against a 
transparent background. 

For selections with intricate edges, you may need a more sophisticated tool to 
help you do the work of selecting.  Choose the Extract command from the 
Filter menu to help you select an area that you plan to move into another 
image, or to create a transparent image for a web graphic.  In the window that 
appears, you can use the Edge Highlighter tool to mark the edges of a 
selection.   
If you need to select an area with intricate or wispy edges, set the Brush Size 
fairly large, or, for areas with well-defined edges, check the Smart 
Highlighting feature.  You can also set the Highlight color with the drop-
down menu.  Click and drag the Highlighter along the edges of the image, 
being sure to cover any wispy areas with a broad brush stroke.    
You can clean up any mistakes with the Eraser tool.  Once you have the 
edges of your selection highlighted, you’ll need to fill the area using the Fill 
Tool.  Just as you can change the color of the highlighter, you can change the 
Fill color using the drop-down menu.  To see what the extracted area might 
look like, press the Preview button. 


