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BAB 2
Membuat dan Menjalankan Form

dengan Single Block

Pada bab ini, akan dibahas cara untuk membuat basic data entry dan query
untuk satu table.

Pada umumnya, data block dalam suatu form berkorespondensi dengan
suatu table dalam database. Tabel ini disebut dengan base table. Untuk setiap
table yang ditampilkan pada form, maka otomatis data block akan dibuat.

Suatu (data) block ditampilkan pada Canvas yang merupakan bagian dari
suatu Window. Ada banyak pilihan untuk mengatur beberapa tampilan canvas dan
window per form. Pada contoh berikut, akan difokuskan pada penggunaan satu
canvas dan satu window.

Ada beberapa cara untuk membuat data block. Salah satu cara adalah
dengan mendefinisikan secara manual base table dan kolom beserta posisi tiap
kolom pada form. Tapi cara ini membutuhkan waktu yang lama. Alternatif lain
yang lebih cepat adalah dengan menggunakan fasilitas wizard.

Oracle Form menyediakan dua wizard untuk membuat data block :

1. Data block wizard
Yang menuntun developer untuk memilih base table dan kolom.
2. Layout wizard
Yang menuntun developer untuk melakukan pengaturan terhadap base

table dan kolom pada form.
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2.1. Membuat (Data) Block Baru

Untuk membuat data block baru, pilih Tools -> Data Block wizard.

Kotak dialog berikut akan muncul :

Data Block Wizard x|

Welcome to the Data Block Wizard!
Thiz wizard allows you to quickly and easily create &

data black based an a table, & view, or & set of stared
procedures [an advanced option).

Click Mext to begin crea'ting vour data block.

v Display thiz page nest time:

Cancel | Help | < Bach | MNext > I Finish |

Klik tombol Next, maka kotak dialog berikut akan muncul :

Data Block Wizard I _>_<J

Select the type of data block you would like to create by
clicking ot a radio button below.

Mite; To baze your data block ona zet of stored )
procedures, pou should have & working knowledge of
PL/SGEL programiting.

" Stored Procedure

Cancel I Help | < Back | Mest > I Firizhy |
Terdapat dua tipe data block yang dapat dibuat, yaitu Table/View dan

Procedure. Untuk contoh yang akan dibahas ini, pilih Table or View kemudian

klik tombol Next.
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Tahap berikutnya adalah memilih base table dan kolom yang menjadi milik

dari data block.

Data Block Wizard i il

Enter a table or wiew on which to base _l,ujur'déta block,
Then zelect the columns that should appear as items,

T able ar wigw

I Browse... |
Befrash | [~ Enforce data integrity

Available Colurms D atabaze [tems

o =W o
L

- ——
HEEE

S
Cancel Help | cgack [ Mews | Fiien |

Untuk mengasosiasikan table database dengan block, klik tombol Browse.

Maka kotak dialog berikut akan muncul :

x

Display:
v Current user [ Tables
[~ Cther users [ \iews

[~ Synonyms
Table I Cwiner
DEPARTMENT
DEPEMDENT

o] 4 Cancel Help |
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Beri tanda check pada Current User dan Tables. Kemudian pilih table
EMPLOYEE.

Setelah itu, pilih kolom yang diperlukan. Sebagai contoh, pilih FNAME,
LNAME, SSN, BDATE, SALARY dan DNO :

Maka pilihan pada kotak dialog akan tampak seperti pada gambar berikut :

Data Block Wizard 5]

Enter & table or view on which to base pour data block,
Then select the colums that should appear as itemns.

Table ar view:

|EMF'LEIYEE Browse... |
Eefresh | I Enforce data integn't_l,l

byallable Calumng Databasze ltems
%] MINIT - FHAME
A ADDRESS > | LleE
& SEx BOATE
- - il SALARY
P M- IPERSS

$<__|
5

B3

Cancel | Help | < Back | Meut = I Firish

Kemudian klik tombol Next, dan sampailah pada akhir dari dialog untuk

Data Block wizard :
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Data Block Wizard B | 5!

Congratulations!

You have finizhed describir_'ug_your data block.

Bn_'-jfl:nr_e wou click Finigh to create your new data block,
click a radio button to tell the Data Block Mizard what
you want to do nest,

{+ Create the data block. then call he Layout Wizand

i Just create the data block

Tou can alzo uge the Dvata Block wizard to modify your
exizting data blocks. :

Simply select the data block in the Object Mavigator and
click the Data Black \Wizard toolbar button, or choose
‘Data Black ‘Wizard' from the 'Tools menu.

Cancel I Help I < Back I MNexts I Finizh I

Untuk melanjutkan ke Layout Wizard, pilih pada “Create the data block,

then call the Layout Wizard” , kemudian klik tombol Finish. Maka muncul kotak

dialog awal dari Layout Wizard akan muncul :

Layout Wizard x|

Welcome to the Layout Wizard!

Thiz wizard allows pou bo quickly and easily lay auk the
itemnz of a data block.

The wizard will dizplay the itemz it a frame on a canvas,
and lay them out in one of zeveral stoles.

Click Mest to begin creating your frams.

Iv Display this page next lime

Cancel | Help < Back | Mext = I Finizh

Klik tombol Next, maka akan muncul kotak dialog berikut :
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Layout Wizard ] _EI

Select the canvas on which you wish to lay out the data
block's items. [F you are creating a new canvas, also be
zure bo zelect the appropriate canvas tupe.

Carreas:  ({IRIRRET

Type:  |Content j

If your select a tab canvasz, then pou-also must select a
tab page on which to lay out the data black's items.

TabBage:  |[Mew Tab Fage] j

Cancel Help ¢ Back | M st I Finizh

Layout untuk suatu data block ditempatkan pada canvas yang sudah ada.
Karena belum ada canvas satupun yang pernah dibuat, maka akan dibuat canvas

baru. Setelah itu klik tombol Next, dan akan muncul kotak dialog berikut :
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Layout Wizard il x|

Select the data block wou I.-_\Iijéh talay out. Then select
the iternz that should be displayed in the frame, and
select an item type far each.

Data Block: IEMF‘LDYEE -]

&ailable ltems Dizplaped lterms

55

Lkl

(e T e |Eh’arl j e |E|Dup "I
Cancel Help < Back | Mest > I Finizh |

Pada kotak dialog diatas, kolom yang ada pada base table dapat ditempatkan

ke layout. Pindahkan semua kolom dengan menekan tombol LI . Setelah itu
tekan tombol Next untuk melanjutkan.

Pada kotak dialog berikutnya, ditampilkan semua kolom yang ditempatkan
pada layout. Ubah prompt teksnya dari prompt default, beserta ukuran teksnya,

seperti yang ada pada gambar berikut :
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Layout Wizard |

Enter a prompt, width, and height for each item. The
unitz for ke width and height are Paints.

Hame Prompt Wid &

FHAME Firzt Mame 17 [
LHAME Last Mame 47 B
IS5 M Soc. Sec. s
BOATE Birth D ate 53
SALARY Salary A7
DMOD Dept. Mumbed 15

=
4 | ha

Cancel Help cBack [ Mew> | Fwish |

Tekan tombol Next, berikutnya akan tampil kotak dialog untuk pemilihan

style dari form yang dibuat :
Layout Wizard Ed

Select a layout style for vour frame by clicking a radio
button below.

" Tabular

Cancel Help < Back | M et I Finizh
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Pilihan Tabular akan mengatur field-field seperti daftar table (seperti Excel),
sedangkan pilihan layout Form akan menempatkan label dari field pada sebelah
kiri teks input.

Untuk contoh pada tutorial ini pilih Form layout kemudian klik tombol
Next.

Berikutnya adalah kotak dialog untuk menuliskan judul frame (kotak
bergaris yang membatasi data block), isi dengan dengan judul Employees.

Kemudian beri tanda check pada Display Scrollbar.

Layout Wizard E

Enter a title far the frame. Alzo be sure to specify the
number of databaze records to be dizplayed in the frame,
az well az the distance between each record.

To dizplay a zcrollbar in the frame that can be used to
goroll through databaze recards, check the 'Display
Scrollbar' check box.

Frame Title: IEH'IF"D.'r'EES

Records Displayed: I'I
Distance Between Records: IEI

[+ Dizplay Scrallbar

Cancel Help ¢ Back | Mext > I Finizh

Setelah menekan tombol Next, maka sampailah pada akhir dari pembuatan

data block dan layout wizard.
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Layout Wizard

Congratulations!

You have finizhed dezcrbing vour layout frame.

To create the new frame and lay out the zelected items,
zimply click Finish.

The Layout Wizard will dizplay the new frame in the
Layout Editor. To modify the layout in the future, you can
recall the Lapout YWizard. Simply zelect the frame in the
Lavout Editor and chooze 'Layout Wizard' from the
‘Toolg' menL.

Hint: To 'fine-tung' the layout, use the Property Palette o
rodify the frame's lapout properties. Selact the frame in

the Lapaut Editar and choosze 'Praperty Palette’ from the
‘Tools' menu.

Cancel |

Help |

< Back |

[[ Finen ]

Setelah menekan tombol Finish, maka akan tampak Layout Editor beserta

form dan data block yang baru saja dibuat.

S MODULE1: CANYASZ [ EMPFLOYEE )

=R gy

F Q]

| i | g .;am,as:|mr-m52 -] Bbck;IEMPLDYEEj ?

ISi[=1E3

Iﬁj Microzoft Sans Serif
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2.2. Menampilkan Property

Pada Layout Editor, jika suatu obyek diklik dua kali, maka akan tampak
jendela property yang menjadi milik obyek tersebut.

Berikut ini jendela property yang muncul setelah obyek field FName diklik
dua kali :

Zh(|E% | Fa| 0 R Finaf |

Item: FHARME

= General |;
@ Mame FHAME

@ [tem Type Text ltem -

+ Subclasz Information

« Comments

» Help Book Topic

= Functional
+ Enabled Yes
« Juztification Start

@ |mplementation Clazz

o Multi-Line Mo

= Wiap Style Wwford

@ Caze Restriction Pined

» Conceal Data Mo

« Keep Curzor Pogition Mo =
2 o LI_I
Froperty Hint

Masing-masing obyek memiliki himpunan property yang berbeda satu sama
lain. Untuk perbandingan, berikut ini adalah property dari Data Block :
Employee. Cara menampilkan properti dari Data Block : Employee yaitu dengan
mengklik dua kali bagian Dara Block yang berisi obyek Employee pada Object

Navigator.
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1.

#i Property Palette =1k

202X T 0 Fingf |

[ata Block: EMPLOYEE

= General | -

@ Mame EMPLOYEE

@ Subclass Information

= Comments -

= Havigahion

= MNavigation Style Same Record

@ Previous Mavigation Data Block | <Mull

= Mext Mavigation D ata Block <Ml

= Records

2 Current Recaord Yisual Attribute G <Mull

= [ueny Array Size 0

@ MNumber of Records Buffered 0

@ Mumber of Records Displayed | 1

= [uemy All Records Mo
= Record Orientation Wertical
-
[l P R o S | Rl
<I | _>I_I
Property Hint

Properti-property yang penting pada suatu Data Block, yaitu :

WHERE Clause

Klausa Where digunakan untuk membatasi pilihan baris yang ditampilkan
dari base table

ORDER BY Clause

Klausa Order by digunakan untuk mengurutkan record-record yang
ditampilkan

Delete Allowed, Insert Allowed, Query Allowed dan Update Allowed
Yaitu perintah untuk memperbolehkan atau tidak memperbolehkan suatu
operasi (delete, insert, query, update) terhadap record dalam base table.
Misal jika Delete Allowed diset FALSE, ini akan mencegah penghapusan
secara tidak sengaja terhadap record yang berkorespondensi dengan base
table.

Beberapa property lainnya yang berhubungan dengan jenis huruf, warna,

ukuran dan posisi obyek dalam block.
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2.3. Menyimpan, Meng-compile dan Menjalankan Form
Untuk menyimpan form, pilih menu File -> Save. Semua file dari suatu
form disimpan dengan ekstensi .fmb  Simpan form yang baru dibuat dengan

nama employee.

savens T

Save in: | ‘- FORMSED ~] « @k @
AP [ JUSEREXIT
em =] test.fmb
java
log
FERL
SEIVET
File narme: Iempluyee Cove I
Save as type: IFl:urms [* frmb] =] Cancel |

Sebelum mengeksekusi atau menjalankan suatu form, maka terlebih
dahulu harus di-compile dan di-built. Proses compile akan menjalankan PL/SQL
Compiler dan semua procedure serta trigger yang ada dalam form. Untuk meng-
compile form, pilih menu Program -> Compile. Hasil dari proses compile adalah
file yang berekstensi .fmx

Untuk melakukan proses built terhadap file .fmx , pilih menu File ->
Administration -> Compile file. Jika proses generate form sukses, akan muncul
pesan di sebelah kiri bawah dari jendela Form Builder : Module built successfully

Alternatif pilihan yang berkenaan dengan build, save dan running adalah

dengan memilih menu Tools -> Preferences.
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i Preferences

Read Only - Shared

-

o ] s | [ He |

Beberapa pilihan diantaranya : apakah akan menyimpan sebelum

melakukan proses build, atau melakukan proses build sebelum menjalankan form.

Untuk menjalankan form gunakan menu Run Form -> Client/server.

Alternatif lain untuk menjalankan form yaitu dengan menekan icon

Form dijalankan pada jendela Oracle Forms Runtime.

£ Oracle Forms Runtime
5| e

N WINDDW1

L [ |
r | [
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Untuk menampilkan record pada form, pada toolbar klik icon Execute

query | % Setelah itu pada layar akan tampil record pertama dari table employee

sebagai berikut :

£ Oracle Forms Runtime - 1o x|
Action Edit Query  Black Record  Figld  Wwindow  Helpe

W | OB TR« 4 b g ?
R B
Employvees
First Mame  [10Hm Lask Marne EMITH S0, Sec. -|123455:-'39
Birth Date ﬁg.J,qN.1955 Salary EDDDD Dept. Mumber F
kil
Fecard: 1/7

Navigasi pada table dilakukan dengan menggunakan tombol aarp
Query by Example (QBE) dapat diimplementasikan pada Oracle Form.
Atau dengan kata lain form yang dijalankan pada jendela Oracle Forms Runtime,
dapat diset ke dalam mode Query. Misal yang akan ditampilkan pada form hanya

employee yang bekerja pada Dept. No = 5.

Untuk melakukan hal ini, pada toolbar klik icon Enter Query ?E ,

kemudian setelah itu isi field Dept. Number dengan nilai 5, dan yang terakhir klik

icon Execute Query |% , maka pada form akan tampil hanya record-record dari

employee yang bekerja di Dept. Number=5.

2.4. Latihan : Membuat Single Block Form
Sebagai latihan buat data entry sederhana untuk table DEPARTMENT, yang
memiliki karakteristik sebagai berikut :
e Memilih dan menampilkan semua kolom dalam table DEPARTMENT

e Pada Layout wizard, gunakan pilihan Tabular layout dan display 5 records

pada form, tambahkan pula scrollbar.
e Pada Layout Editor, buat field DNAME yang dapat memuat panjang

semua nama department, kalau perlu field ini diperpanjang size-nya.
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Ubah property dari block DEPARTMENT sehingga data yang ditampilkan
diurutkan berdasarkan DNUMBER

e Simpan form dengan nama : depart.finb

Gunakan enter query mode dan fungsi execute query untuk melakukan query
terhadap table department. Hasilnya akan seperti ini :

£ Dracle Forms Runtime

=
Action Edit Query Block Record Field Window Help
T % 3 . :
WEsa| k| XEE | HE%E | « 4 r » | @l ?
BEEE
—— Department
Cname Cnumber  Marssn Marstartdate
ESEARCH 33445555 2-May-1975 ;I
FADMIMISTRATION 37654321 1-14aK-1985
EADQUARTERS 1 SHE65555  [19-JUN-1971
[Fecord: 143 |

Halaman - 25



