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BAB 4
MEMBUAT LIST OF VALUE (LOV) DAN
NON-BASE TABLE FIELDS

Merupakan suatu hal yang sangat menjemukan bagi user untuk mengingat
begitu banyak kode dan bilangan pada saat memasukkan data pada form entry.
Sebagai contoh, pada form Employee, akan sulit untuk mengingat semua nama
department pada waktu menyisipkan data pegawai baru.

Solusi untuk mengatasi masalah ini adalah dengan membuat daftar nilai
yang tersedia pada user melakukan navigasi pada field nomer department (DNO).
Cara seperti ini disebut dengan List of Values (LOV). Contoh yang akan
diberikan berikut ini mengilustrasikan pembuatan LOV pada form Employee
seperti yang dibuat pada awal tutorial.

Untuk itu, pilih menu File -> Open, kemudian buka file employee.fmb
LOV didasarkan pada Record Group. Dalam Oracle, record group adalah query
yang mengembalikan kumpulan record.  Record group digunakan untuk
mengumpulkan (populate) block atau LOV dan dapat digunakan dalam suatu
prosedur. Pada saat user melakukan navigasi terhadap item yang memiliki LOV,
tombol LOV (tombol F9) ditekan untuk memanggil LOV. Maka query yang
berasosiasi dengan record group dijalankan dan hasilnya ditampilkan dalam pop
up. Pada saat user memilih salah satu nilai yang ada pada list, maka nilai tersebut
akan dikembalikan ke form dan disimpan dalam suatu field.

Pada contoh berikut, akan dibuat record group dan LOV untuk field DNO

(nomer departemen) dalam table Employee.
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4.1. Membuat List of Values (LOYV)

Untuk membuat LOV, pertama-tama perlu dibuat obyek LOV baru. Klik LOV

yang ada pada Object Navigator. Kemudian pada menu pull down pilih Create

|TEI. Kotak dialog akan tampil seperti gambar dibawah yang menanyakan apakah

akan dibuat LOV secara manual atau dengan LOV wizard

i EMPLOYEE: New List-Of-Yalues (LOY

Create a new List-0f-Yalues (LW

di

" Build a new LOW manually

ok Zancel

x|

Help

Pilih "Use the LOV Wizard" kemudian klik OK. Tampilan pertama dari LOV

Wizard seperti berikut :

LO¥ Wizard

LO%s get their data from Record Groups, which may be
populated using SAL queries, or by entering & static list
of walues.

Do ypou wank bo base your LOY on & new Becord Group,
or uge an existing Record Group? [F you want a hew
Record Group, vou must baze that Becord Group on a
SOL quen.

i+ MNew Record Group based on a queng

" Exicting Becord Group

Cancel Help

Finizh

i Bank: | M eut I

Kemudian klik tombol Next.

Untuk tampilan berikutnya, tulis query sebagai berikut : SELECT DNUMBER FROM

DEPARTMENT
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LOV Wizard ]|

Fecord Groupz can be bazed on SOL gueriez. Do you
want to enter or modify the querny that your LOY's Record
Group uses?

If 2o, wou may uge the Oracle Developer Query Builder

by clicking Build SGL Guery. Or, you may enter your
query directly inta the SCL Query Statement field below.

Build SOL Querny... Impart SOL Querny. ..

SOL Query Statement
SELECT DMUMBER FROM DEFARTRMEMT

LCaonnect. . | i Check Syntax.

Cancel Help < Back | Meat » Finizh

Kemudian klik tombol Next.  Tahap berikutnya adalah menentukan

kolom dalam record group yang akan digunakan oleh LOV. Pada contoh ini, pilih

DNUMBER, arahkan dengan tombol —>| ke kotak sebelah kanan, kemudian
klik tombol Next.
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LO¥ Wizard 3 x|

our LOYW: may include some or all of the columns in the
Record Group. *hich Record Group coluring do yaou
wizh to include in pour LOY? '

Becord Growup Coluring LOY Columnis

DHIUMBER

e

EEEE

Cancel Help ¢Back [ Mew> | Finish

Tahap berikutnya adalah menentukan properti display dari kolom LOV
dan juga memetakan LOV ke field yang ada pada form.

LOY Wizard x|

[F pou wizh to specify the LOY column properties, youl
may entera title, width and retum value for each LOY
column,: The unitz for the colurmn width iz Pointz;

Column Title Width Fa
DHIJMBER D number 27 =

4 I i

[ Automatically size columns

Cancel Hep | < Back News> | Finish |
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Untuk memetakan kolom LOV ke field, klik pada entri DNUMBER

kemudian klik pada tombol "Look up return Item". Pilih field EMPLOYEE.DNO
kemudian klik tombol OK.

Items and Parameters _ 1 l!
Firid FMF‘LO"{EE.%
MPLOYEE . FMAME -

MPLCYEE SALARY

Find | Cancel

Catatan : jika LOV berisi lebih dari satu item, maka pada saat yang sama item-

item tersebut harus dipetakan (akan dicontohkan pada bab selanjutnya).

Tahap berikutnya adalah menentukan judul untuk jendela LOV, dan
menentukan ukuran serta posisi dari LOV. Isi seperti pada tampilan berikut,

kemudian klik tombol Next.
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LO¥ Wizard il x|

“wéhat title wolld pou fike to display in pour LOY windo?

Title; |Choose a Department Mumber

Wihat size would pou ke your LOY b be? The uhits for
the LOY size and position are Points.

width: |'|3|:I Height: |135

Do pau want Forme Rurntime ta positian pour LOW?
+ ez, let Forms pasition my LOW autormatically

" Ma, | wart to pozition it marnually

LLeft: |'_-| Tiap: ||:I

Cancel | Help | 4 Back | Mest = I Finizh |

Tampilan berikutnya ini menentukan bagaimana cara suatu record di fetch ke
dalam LOV. Jika terdapat ratusan bahkan ribuan record yang mungkin bisa
dimasukkan ke dalam LOV, maka option seperti yang ada pada tampilan berikut
perlu diubah. Jika tidak terlalu banyak, isi dengan pilihan seperti berikut,
kemudian tekan tombol Next.

LO¥ Wizard x|

Do o want to modify the advanced properties that
affect the behavior of your LOW?

If wou &re naok fariliar with their usage. itis recommended
that pou accept the defaults a5 they appear below,

Retriswve |t2|:| rawe at a time.,
v Refiesh recard group data before displaping LOW

[~ Let the uzer filker recards before displaying them

Cancel Help cBack |[ Mews | Fiish |
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Pada tahap yang terakhir, LOV akan mengembalikan beberapa kolom ke
field pada form seperti yang ada pada tahap sebelumnya. Pada tahap ini, kita
perlu mengasosiasikan LOW dengan suatu item pada form. Sebagai contoh, kita
asosiasikan LOV ke field EMPLOYEE.DNO, maka user akan memanggil LOV,
hanya pada saat cursor berada pada posisi field DNO. Pilih EMPLOYEE.DNO,

kemudian klik tombol Next.

LOY Wizard ' j x|

'ou are returning values from pour LOY ta the fallowing
items. Y'ou may assigh pour LOYW ta some or all of these
items.

T o which of these ftems da vau wish to assign yaur
Ly

Beturn ltems Aszsigned |tems
EMPLOYEE.DMNDO

PLLL

Cancel Help: < Back | Hext > I Finizh

Dan yang terakhir, klik tombol Finish untuk membuat Record Group dan LOV.
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LO¥ Wizard x|

T create the new LOY and any associated Record
Group, click Finish. The Object Mavigator will display an
entry for pour new LOY.

To madify the LDV in the future, vou can recall the LOY
Wizard, To do'so, select the LOY in the Mavigatar, and
choose LOV Wizard from the Tools Menu.

Caricel Help: < Back . NEsts | Firish I

Pada gambar dibawah ini, LOV yang telah dibuat terlihat pada Object
Navigator. LOV dengan nama default yaitu LOV4 berada pada LOV dan record
group yang berasosiasi. Nama default yang muncul tergantung pada bagian mana

dari tutorial yang diselesaikan, dan bisa berubah untuk keadaan yang lain.
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Object Mavigator : 0o x}
o i S %

El-Forms

(= 54 EMPLOYEE

~Triggers

- Alerts

~Attached Libraries
~Data Blocks
“Canvases

‘Editors

1Y |

- [ (e
‘Object Groups
Parameters
‘Popup Menus
“Program Units
- Property Classes

“Reporkts

- ¥isual Attributes
- Windows
[1-Menus

[1-PL/SQL Libraries

= | O 0Object Libraries _ILI
F

Simpan, compile dan jalankan form. Pada waktu memasukkan data baru,

=
£

navigasi field DNO (Department number). Perhatikan pada bagian bawah form
ada pesan tertulis : List of values yang menandakan daftar nilai yang tersedia
untuk field ini.

Pada MS Windows 95/98/NT/2000 tombol untuk menampilkan list of
values adalah tombol F9. Untuk melihat tombol yang berasosiasi dengan suatu
operasi tertentu, pilih menu Help -> Keys.

Tampilan berikut ini memperlihatkan pengisian record baru dan
pemakaian List of Values (LOV) dari field DNO (nomer departemen) setelah
mengklik tombol F9.

Halaman - 51



Oracle Developer

@Tessy Badriyah
i
Employees
Firsk Mame  kessy Last Mame  hadrivah Soc, Sec, 5432
Birth Date  [14-sEp-0070 Salary k44353 Diept. humber I_
=
Find F.-"o

Find | o, I Cancell

4.2. Non Base Table fields

Pada contoh sebelumnya kita tambahkan List of Value untuk menyediakan
suatu daftar yang dapat dipilih oleh user pada saat melakukan entri data baru.
Akan tetapi dari LOV yang dibuat, akan lebih membantu jika yang ditampilkan
adalah nama dari departemen bukan nomer departemennya. Akan tetapi nama
departemen ini (DEPTNAME) tidak termasuk anggota dari table atau data block
EMPLOYEE. Maka kita perlu cara untuk menampilkan informasi ini pada data
block EMPLOYEE yang disebut dengan non base table field.

Lakukan tahapan berikut ini :

1. Tentukan item yang akan ditambahkan ke data block EMPLOYEE, yaitu
DEPTNAME.

2. Berikutnya, field DEPTNAME ini harus dikumpulkan (populate) setiap
saat terjadi perubahan pada field DNO. Trigger akan dibuat untuk
menangani fungsionalitas ini.

3. Dan yang terakhir, list of values akan berubah dengan memasukkan nama

departemen ke dalam LOV.
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4.2.1. Menambahkan item baru pada data block yang sudah ada
Aktitkan Layout Editor dengan memilih menu Tools -> Layout Editor.

Klik padaicon @l untuk membuat field baru pada block EMPLOYEE.

Ubah namanya pada Object Navigator dengan nama DEPTNAME :

M8 EMPLOYEE: CANVAS2 [ EMPLOYEE ) - [O] x|
O sEE | KER| A g =k Canvas; [CANVAS2 | Block;[EMPLOVEE -] 2 ‘

I'.'ﬂj Microsoft 5 ans Senf j | IB j | B ru | );‘i‘) =N | = = =00t | ol | P,
#Jn [T6 |32 |48 |64 |80 |9 |1‘I2|128|144|1BD|1?E|192|2I'r]8|224|24D|258|2?2|288|304|32D|335|352|388|384|4DD|41E|432|448|484i|
WE 0 '
'?K 0 16 | Employees
L[~z Fist  [FNAME Last [LHAME Soc. [55N -
i Ngme Mame Sec.

C Bith  [EDATE Salary [GALARY Dept.  [DNO
@ O B4 Date Mumber = |-

| f{DEPTNAME i
] e = i
T[djw

pt =

p4

Bl 25258 [ 11zs0

Tampilkan Properti DEPTNAME dengan mengklik dua kali, kemudian ubah
propertinya seperti berikut :
e Enabled: Yes
e Keyboard Navigable : No
e Database Item : No
e Query Only : No
e Primary Key : No
e Insert Allowed : No
e  Query Allowed : No
e Update Allowed : No
Keyboard Navigable diset ‘No’ maksudnya untuk mencegah user
melakukan tab pada field ini. Sedangkan Database Item diset ‘No’ menandakan
bahwa field ini tidak dipetakan ke kolom yang sebenarnya pada table
EMPLOYEE. Untuk property yang lainnya pada daftar diatas diset ‘No’ untuk
mencegah field dari aktifitas : Delete, Insert, Update dan Query.
Dengan pembuatan field baru tersebut, item DEPTNAME akan
ditambahkan ke dalam data block EMPLOYEE sebagai non base table field.
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4.2.2. Pembuatan Trigger
Berikutnya akan dibuat trigger untuk memperbaharui field DEPTNAME
pada saat nilai dari DNO berubah.
Trigger dalam form Oracle memiliki tiga bentuk, yaitu :
PRE - Trigger akan diaktifkan sebelum suatu event dijalankan

POST — Trigger akan diaktifkan setelah suatu event dijalankan.

WMo

WHEN - Trigger akan diaktifkan pada saat suatu event dijalankan

4. KEY - Trigger akan diaktifkan pada saat ditekan suatu tombol tertentu
Pada contoh ini, kita memperbaharui field DEPTNAME setelah terjadi perubahan
pada field DNO. Untuk itu kita gunakan trigger POST-CHANGE pada field
EMPLOYEE.DNO

e Pada field DNO yang menjadi milik data block EMPLOYEE, klik triggers.

& Object Mavigator =] B3
Triggers ] Find| ¥, "%J

- Canvaszes
#-E CanNvas?

El Editors _Ij
=101 Ml
F

e Kemudian buat trigger baru dengan memilih pada menu Navigator ->

!
(7| =- Forms =)

~u =1 EMPLOYEE
s I:I---Triggers
i I;I---Alerts
— [1-Attached Libraries
:EJ: EI---[ZEIata Blocks

El% EMPLOYEE

% [~ Triggers
o El- Items
o FHAME
5 B LNAME

: FH-Red S55M
- BDATE o
el B SALARY
. E| OMO
% oo
xEl [-Bkl DEPTHAME

[J-Relations

=
F|

=

Create.

e Pilih POST-CHANGE trigger, kemudian klik OK.
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EMPLOYEE: Triggers Ed
Find IZ
OM-MESSAGE -
OM-SEQUENCE-MLUMBER

POST-CHAMGE
POST-TEXTATEM
FRE-POPUP-MENL
FRE-TE=T-ITEM
HEM-CLEAR-BLOCK,
HEM-CREATE-RECORD
HEM-DATABASE-RECORD J
HEM-FOLSE-CLICE.
HEMW-MOUSE-DOUBLECLICE,

HEM-MOISE-D O M -
|‘|'I|II_I.I WO ICrE reITEM Iﬂ—l
Find | Cancel |

Setelah tampil PL/SQL editor, ketikkan kode PL/SQL berikut :

-- Populate the non base table field : EMPLOYEE.DEPTNAME
-- Using a value from DEPARTMENT TABLE
BEGIN

SELECT DNAME

INTO :EMPLOYEE.DEPTNAME

FROM DEPARTMENT

WHERE DEPARTMENT.DNUMBER = :EMPLOYEE.DNO;
END;

Lakukan proses compile pada trigger dengan mengklik tombol Compile.

Setelah selesai di-compile tutup PL/SQL editor dengan mengklik tombol Close.

4.2.3. Membuat List of Values (LOV) yang baru
Pada bagian ini kita akan membuat LOV baru yang dapat menampilkan nomer
dan nama departemen.
e Dari Object Navigator, klik LOV pada form EMPLOYEE.
e Pilih menu Navigator -> Create. Setelah tampil kotak dialog, pilih LOV
Wizard
e Masukkan perintah SQL berikut pada field Query Text :
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SELECT DEPARTMENT.DNUMBER, DEPARTMENT.DNAME
Kemudian klik tombol Next.

Petakan kolom DNUMBER pada LOV dengan :EMPLOYEE.DNO dan

DEPTNAME pada LOV dengan :EMPLOYEE:DEPTNAME.
LOY Wizard

IF wou wizh to zpecify the LOW colurmn properties, pou
may enter a title, width and return value for each LOW
caolumn. The units for the column width iz Pointz.

Title Width Return value -
Cept. Mumber  [24 EMPLOYEE.DMO
Dept. Mame 95 MPLOYVEE.DEFTHAME | 7

-
l D

Cancel Help | < Back | Mext » | Finizh |

Berikan judul pada LOV, dan pilih DNUMBER dan DNAME dari daftar
supaya keduanya ditampilkan pada saat LOV diaktifkan.

e Terakhir simpan, compile dan jalankan form. Hasilnya seperti berikut :

-0l x|
— Employees
First [tessy Last |badripah Soo. I342 -
Mame: Mame Sec. iy
Bith [14-5EP-1970 Salary. [432342 Dept. |
Date. Mumber j
Choose a Department x|

4 ADMINISTRATION
1 HEADGUARTERS
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4.3. Latihan : Membuat LOV dan Non base table field

Sebagai latihan, buat single data block baru yang berisi semua kolom yang

ada pada table DEPARTMENT. Kemudian tambahkan non base table field untuk

nama akhir (last name) dari manajer departemen dan buat LOV yang menampung

semua kemungkinan nilai kode ssn dari seorang manajer (field Mgrssn).

ELLTTEE =loix|

Buat form baru dengan nama departmg.fmb yang berisi semua kolom
dalam table DEPARTMENT. Pada Layout wizard gunakan tipe layout
Tabular dan tampilkan 5 record pada form, juga tambahkan scroll bar.
Pada Layout Editor, buat item text baru dengan nama
MGR_LAST_NAME pada data block DEPARTMENT yang telah dibuat.
Set properti untuk MGR_LAST_NAME sebagai suatu teks yang bukan
termasuk item database.
Buat list of values (LOV) yang diberi nama LOV_MGR berdasarkan
query berikut :

o SELECT ssn,Jlname FROM EMPLOYEE
Tandai LOV_MGR terhadap item MGRSSN, dengan membuat trigger
POST_CHANGE pada item MGRSSN :

SELECT Iname

INTO :DEPARTMENT.MGR_LASTNAME

FROM EMPLOYEE

WHERE EMPLOYEE.SSN=DEPARTMENT.MGRSSN;
Hasil dari form setelah dijalankan, seperti gambar di bawah ini :

— Department
; Dname Drumber Marssn Marstartdate [Mar Lask Marne
RESEARCH [33445555 [pz-tay-1975 QNG ]
FADMIMISTRATICN Choose 55N for a manager |
EADQUARTERS 1
Find |%

Bsn Lriamme: -

. SMITH
333445555 WONG

999587777 ZELAYA

087654321 WaALLACE =i i
EEmOAAAA KIAT AWAR d
1] Pl
Find | Cancel |
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